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Some clients using SynMobile have identified intermittent errors being surfaced.

Further effort to remediate this has been called out for in our Feature Roadmap

Cause 

Dev Team have conducted some internal testing and found that the failure point was the SqlLite database 

Resolution

DSY-12454 Initially available in a Patch Form:

  • WebService V69.13.00

Updates are rolled out from v69.13.

Release note for this are at Synergetic Suite v69.13

Clients on earlier versions can have a hot fix appliedSqlLite database under load.  The SqlLite database sits on the web server in a folder such as D:\SynMobile\SqlLite and is used for caching the credentials on the web server for Speed.

When a few client mobile apps connect to the Webservice at the same time the API performs as expected.

The tests found that when there are multiple concurrent connections the Web service would intermittently get this error  "Exception occurred ReviveSqlLiteSession"

Resolution 

A refactoring project was done as part of DSY-12454 completed 30/10/2018

The improvements are listed below:

  1. Remove SqlLite database 
  2. Store all Mobile Session activity in the table: MobileSession
  3. Store all Mobile API Activity in MobileSessionHistory so there is an audit log of what the SynMobile App users are doing
  4. Store the PINs in MobilePin
  5. Split the Session Expiry and PIN Expiry in to separate logic
  6. Shift these ExpiryMinutes values out of the XML file and in to the Config Table
    1. SynMobile|Session|KeepAliveMinutes  (Default 20160 - 2 Weeks)
    2. SynMobile|PIN|KeepAliveMinutes   (Default 262080 - 26 Weeks)
  7. Handle session expiry and Pin expiry situations clearer : tell the user the Session or PIN has expired and they need to log in again

Fix Available

Available in v69.14 onwards.

Can be made available with any V68 and V69 version- please contact support for more information.